From f4171c75fa584324bf1913d133a164068827893f Mon Sep 17 00:00:00 2001
From: nico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Mon, 17 Oct 2005 22:12:30 +0000
Subject: [PATCH] add libvorbisidec package (thanks to David Collet)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2155 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/package/Config.in                     |  1 +
 openwrt/package/Makefile                      |  1 +
 openwrt/package/libvorbisidec/Config.in       | 11 +++
 openwrt/package/libvorbisidec/Makefile        | 91 +++++++++++++++++++
 .../libvorbisidec/ipkg/libvorbisidec.control  |  8 ++
 5 files changed, 112 insertions(+)
 create mode 100644 openwrt/package/libvorbisidec/Config.in
 create mode 100644 openwrt/package/libvorbisidec/Makefile
 create mode 100644 openwrt/package/libvorbisidec/ipkg/libvorbisidec.control

diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 0734eab70..e466dcd90 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -183,6 +183,7 @@ source "package/libtasn1/Config.in"
 source "package/libupnp/Config.in"
 source "package/libusb/Config.in"
 source "package/libvorbis/Config.in"
+source "package/libvorbisidec/Config.in"
 source "package/libxml2/Config.in"
 source "package/libxslt/Config.in"
 source "package/uclibc++/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 0e0e64e29..2d02d3d77 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -94,6 +94,7 @@ package-$(BR2_PACKAGE_LIBTOOL) += libtool
 package-$(BR2_PACKAGE_LIBUPNP) += libupnp
 package-$(BR2_PACKAGE_LIBUSB) += libusb
 package-$(BR2_PACKAGE_LIBVORBIS) += libvorbis
+package-$(BR2_PACKAGE_LIBVORBISIDEC) += libvorbisidec
 package-$(BR2_PACKAGE_LIBXML2) += libxml2
 package-$(BR2_PACKAGE_LIBXSLT) += libxslt
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
diff --git a/openwrt/package/libvorbisidec/Config.in b/openwrt/package/libvorbisidec/Config.in
new file mode 100644
index 000000000..6532c71e5
--- /dev/null
+++ b/openwrt/package/libvorbisidec/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBVORBISIDEC
+	tristate "libvorbisidec - a fixed-point implementation (Tremor) of libogg/libvorbis"
+	default m if CONFIG_DEVEL
+	help
+	  libvorbisidec is "tremor", a fixed-point implementation of libvorbis.
+	  It also has libogg built-in. It is suitable as a replacement for 
+	  libvorbis and libogg in tremor-aware applications.
+	  Tremor is a decoder only.
+	  
+	  http://http://wiki.xiph.org/index.php/Tremor
+	  
diff --git a/openwrt/package/libvorbisidec/Makefile b/openwrt/package/libvorbisidec/Makefile
new file mode 100644
index 000000000..6b78e746d
--- /dev/null
+++ b/openwrt/package/libvorbisidec/Makefile
@@ -0,0 +1,91 @@
+# $Id: Makefile,v 1.2 2005/10/07 17:05:47 nico Exp $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbisidec
+PKG_VERSION:=1.2.0-dave
+PKG_RELEASE:=1
+PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
+
+PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBVORBISIDEC,libvorbisidec,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+	(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+		$(TARGET_CONFIGURE_OPTS) \
+		CFLAGS="$(strip $(TARGET_CFLAGS))" \
+		CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+		LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+		PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+		./configure \
+			--target=$(GNU_TARGET_NAME) \
+			--host=$(GNU_TARGET_NAME) \
+			--build=$(GNU_HOST_NAME) \
+			--program-prefix="" \
+			--program-suffix="" \
+			--prefix=/usr \
+			--exec-prefix=/usr \
+			--bindir=/usr/bin \
+			--datadir=/usr/share \
+			--includedir=/usr/include \
+			--infodir=/usr/share/info \
+			--libdir=/usr/lib \
+			--libexecdir=/usr/lib \
+			--localstatedir=/var \
+			--mandir=/usr/share/man \
+			--sbindir=/usr/sbin \
+			--sysconfdir=/etc \
+			$(DISABLE_LARGEFILE) \
+			$(DISABLE_NLS) \
+			--enable-shared \
+			--enable-static \
+			--disable-rpath \
+			--with-gnu-ld \
+	);
+	touch $@
+
+$(PKG_BUILD_DIR)/.built:
+	rm -rf $(PKG_INSTALL_DIR)
+	mkdir -p $(PKG_INSTALL_DIR)
+	$(MAKE) -C $(PKG_BUILD_DIR) \
+		DESTDIR="$(PKG_INSTALL_DIR)" \
+		all install
+	touch $@
+
+$(IPKG_LIBVORBISIDEC):
+	install -m0755 -d $(IDIR_LIBVORBISIDEC)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(IDIR_LIBVORBISIDEC)/usr/lib/
+	$(RSTRIP) $(IDIR_LIBVORBISIDEC)
+	$(IPKG_BUILD) $(IDIR_LIBVORBISIDEC) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libvorbisidec.so: $(PKG_BUILD_DIR)/.built
+	mkdir -p $(STAGING_DIR)/usr/include
+	cp -fpR $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
+	mkdir -p $(STAGING_DIR)/usr/lib
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.a $(STAGING_DIR)/usr/lib/
+	cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so* $(STAGING_DIR)/usr/lib/
+	touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libvorbisidec.so
+
+uninstall-dev:
+	rm -rf \
+		$(STAGING_DIR)/usr/include/tremor \
+		$(STAGING_DIR)/usr/lib/libvorbisidec.a \
+		$(STAGING_DIR)/usr/lib/libvorbisidec.so* \
+
+compile: install-dev
+clean: uninstall-dev
+
+mostlyclean:
+	-$(MAKE) -C $(PKG_BUILD_DIR) clean
+	rm -f $(PKG_BUILD_DIR)/.built
+
diff --git a/openwrt/package/libvorbisidec/ipkg/libvorbisidec.control b/openwrt/package/libvorbisidec/ipkg/libvorbisidec.control
new file mode 100644
index 000000000..a1e66fa15
--- /dev/null
+++ b/openwrt/package/libvorbisidec/ipkg/libvorbisidec.control
@@ -0,0 +1,8 @@
+Package: libvorbisidec
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, David Collett <daveco@users.sourceforge.net>
+Source: buildroot internal
+Description: A fixed-point implementation (Tremor) of libogg/libvorbis"
-- 
2.20.1