From f5de7192504330724d9cf5615775b22b486f42f8 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Tue, 5 Aug 2008 01:01:27 +0000
Subject: [PATCH] only build avr32 u-boot if requested, fixes build failure in
 default config

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12116 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/avr32/image/Makefile | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 2cef2653b..c74efbe1d 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+  define Build/Clean
 	$(MAKE) -C u-boot clean
-endef
+  endef
 
-define Build/Compile
+  define Build/Compile
 	$(MAKE) -C u-boot compile
-endef
+  endef
+endif
 
 define Image/Prepare
 	cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
-- 
2.20.1