From feab1d97643b297d3b1231c48edbb10a832681b5 Mon Sep 17 00:00:00 2001
From: nbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Fri, 24 Feb 2006 20:59:09 +0000
Subject: [PATCH] fix make target/linux/package/*-clean

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3271 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 openwrt/target/Makefile               | 6 ++++--
 openwrt/target/linux/package/Makefile | 4 +++-
 2 files changed, 7 insertions(+), 3 deletions(-)

diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index e066fa9d3..24c34036d 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -16,6 +16,9 @@ clean: linux-clean utils-clean lzma-clean image_clean
 image_clean:
 	rm -f $(BIN_DIR)/openwrt-*
 
+linux/package/%:
+	$(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+
 %-clean:
 	@$(TRACE) target/$(patsubst %-clean,%,$@)-clean
 	$(MAKE) -C $(patsubst %-clean,%,$@) clean
@@ -35,5 +38,4 @@ linux-imagebuilder:
 	@$(TRACE) target/linux/imagebuilder
 	$(MAKE) -C linux imagebuilder
 
-linux/package/%:
-	$(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index a2567ea6b..77a0583fd 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -55,7 +55,9 @@ KPKG_MAKEOPTS += BUILD_DIR="$(LINUX_BUILD_DIR)"
 
 %-clean:
 	@$(START_TRACE) "target/linux/package/$(patsubst %-clean,%,$@)-clean: "
-	@$(MAKE) -C $(patsubst %-clean,%,$@) clean
+	@$(MAKE) -C $(patsubst %-clean,%,$@) \
+		$(KPKG_MAKEOPTS) \
+		clean
 	@$(CMD_TRACE) " done"
 	@$(END_TRACE)
 
-- 
2.20.1