debian/rules: temporary installation directory is removed after .deb file has been...
[iserv-mod-room-reservation.git] / debian / rules
index 821db46..bd00f34 100755 (executable)
@@ -1,88 +1,62 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# rules for debuild
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-
-#configure: configure-stamp
-#configure-stamp:
-#      dh_testdir
-#      # Add here commands to configure the package.
-#
-#      touch configure-stamp
-#
-
-build: build-stamp
-
-build-stamp: 
-       #configure-stamp 
+# needed for lintian
+build:
        dh_testdir
 
-       # Add here commands to compile the package.
-       $(MAKE)
-       touch $@
+binary-indep: 
+       -$(MAKE) clean
+       dh_clean
 
-clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       #-$(MAKE) clean
-
-       dh_clean 
+       dh_clean -k 
+       dh_installdirs
+       $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-mod-room-reservation install
 
-install: build
+       # we rather install the documentation via dh_installdocs
+       rm -rf $(CURDIR)/debian/iserv-mod-room-reservation/usr/share/doc/iserv-mod-room-reservation
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs
-       # Add here commands to install the package into debian/iserv-room-reservation.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-room-reservation install
+       dh_installchangelogs 
+       dh_installdocs doc/{changelog.old.html,TODO} doc/source/
+       #dh_installexamples
+       ##dh_install
+       ##dh_installmenu
+       ##dh_installdebconf     
+       ##dh_installlogrotate
+       ##dh_installemacsen
+       ##dh_installpam
+       ##dh_installmime
+       ##dh_python
+       #dh_installinit
+       #dh_installcron
+       #dh_installinfo
+       #dh_installman
+       #dh_link
+       #dh_strip
+       dh_compress
+       dh_fixperms
+       ##dh_perl
+       ##dh_makeshlibs
+       dh_installdeb
+       #dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+       rm -rf $(CURDIR)/debian/iserv-mod-room-reservation
+
+# needed for lintian
+binary-arch:
 
+binary: binary-indep
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+clean:
+       dh_testdir
+       dh_testroot
+       -$(MAKE) clean
+       dh_clean 
 
-# Build architecture-dependent files here.
-binary-arch: build install
-#      dh_testdir
-#      dh_testroot
-#      dh_installchangelogs 
-#      dh_installdocs
-#      dh_installexamples
-##     dh_install
-##     dh_installmenu
-##     dh_installdebconf       
-##     dh_installlogrotate
-##     dh_installemacsen
-##     dh_installpam
-##     dh_installmime
-##     dh_python
-##     dh_installinit
-##     dh_installcron
-##     dh_installinfo
-#      dh_installman
-#      dh_link
-#      dh_strip
-#      dh_compress
-#      dh_fixperms
-##     dh_perl
-##     dh_makeshlibs
-#      dh_installdeb
-#      dh_shlibdeps
-#      dh_gencontrol
-#      dh_md5sums
-#      dh_builddeb
+.PHONY: build clean binary-indep binary install
 
-binary: binary-indep
-          #binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
This page took 0.023204 seconds and 4 git commands to generate.