fix lintian warnings and errors
[iserv-mod-room-reservation.git] / debian / rules
index 3b1e5e8..2d79ba9 100755 (executable)
@@ -4,18 +4,24 @@
 # needed for lintian
 build:
        dh_testdir
+       rm -f dirs files
 
 binary-indep: 
+       [ ! -f Makefile ] || $(MAKE) clean
+       dh_clean
+
        dh_testdir
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       sudo $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-room-reservation install
-       
+       $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-mod-room-reservation install
+
+       # we rather install the documentation via dh_installdocs
+       rm -rf $(CURDIR)/debian/iserv-mod-room-reservation/usr/share/doc/iserv-mod-room-reservation
        dh_testdir
        dh_testroot
        dh_installchangelogs 
-       dh_installdocs
+       dh_installdocs doc/changelog.old.html doc/TODO doc/source/
        #dh_installexamples
        ##dh_install
        ##dh_installmenu
@@ -40,6 +46,7 @@ binary-indep:
        dh_gencontrol
        dh_md5sums
        dh_builddeb
+       rm -rf $(CURDIR)/debian/iserv-mod-room-reservation
 
 # needed for lintian
 binary-arch:
@@ -49,8 +56,8 @@ binary: binary-indep
 clean:
        dh_testdir
        dh_testroot
-       -$(MAKE) clean
-       dh_clean 
+       [ ! -f Makefile ] || $(MAKE) clean
+       dh_clean
 
 .PHONY: build clean binary-indep binary install
 
This page took 0.049949 seconds and 4 git commands to generate.