make fails if shell is not bash -- I will fix bashisms somewhere in the future
[iserv-mod-error-reporter.git] / debian / rules
1 #!/usr/bin/make -f
2 # rules for debuild
3
4 # needed for lintian
5 build:
6 dh_testdir
7
8 binary-indep:
9 -$(MAKE) clean
10 dh_clean
11
12 dh_testdir
13 dh_testroot
14 dh_clean -k
15 dh_installdirs
16 $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-mod-error-reporter install
17
18 # we rather install the documentation via dh_installdocs
19 rm -rf $(CURDIR)/debian/iserv-mod-error-reporter/usr/share/doc/iserv-mod-error-reporter
20 dh_testdir
21 dh_testroot
22 dh_installchangelogs
23 dh_installdocs doc/changelog.old.html doc/TODO doc/source/
24 #dh_installexamples
25 ##dh_install
26 ##dh_installmenu
27 ##dh_installdebconf
28 ##dh_installlogrotate
29 ##dh_installemacsen
30 ##dh_installpam
31 ##dh_installmime
32 ##dh_python
33 #dh_installinit
34 #dh_installcron
35 #dh_installinfo
36 #dh_installman
37 #dh_link
38 #dh_strip
39 dh_compress
40 dh_fixperms
41 ##dh_perl
42 ##dh_makeshlibs
43 dh_installdeb
44 #dh_shlibdeps
45 dh_gencontrol
46 dh_md5sums
47 dh_builddeb
48
49 # needed for lintian
50 binary-arch:
51
52 binary: binary-indep
53
54 clean:
55 dh_testdir
56 dh_testroot
57 -$(MAKE) clean
58 dh_clean
59
60 .PHONY: build clean binary-indep binary install
61
This page took 0.051208 seconds and 5 git commands to generate.