moved .deb install and update scripts into new iservchk script
[iserv-mod-error-reporter.git] / debian / rules
1 #!/usr/bin/make -f
2 # rules for debuild
3
4 # needed for lintian
5 build:
6 dh_testdir
7
8 binary-indep:
9 [ ! -f Makefile ] || $(MAKE) clean
10 dh_clean
11 dh_testdir
12 dh_testroot
13 dh_clean -k
14 dh_installdirs
15 $(MAKE) DESTDIR=$(CURDIR)/debian/iserv-mod-error-reporter install
16 # we rather install the documentation via dh_installdocs
17 rm -rf $(CURDIR)/debian/iserv-mod-error-reporter/usr/share/doc/iserv-mod-error-reporter
18 dh_testdir
19 dh_testroot
20 dh_installchangelogs
21 dh_installdocs doc/changelog.old.html doc/TODO doc/source/
22 dh_compress
23 dh_fixperms
24 dh_installdeb
25 dh_gencontrol
26 dh_md5sums
27 dh_builddeb
28
29 # needed for lintian
30 binary-arch:
31
32 binary: binary-indep
33
34 clean:
35 dh_testdir
36 dh_testroot
37 [ ! -f Makefile ] || $(MAKE) clean
38 dh_clean
39
40 .PHONY: build clean binary-indep binary install
41
This page took 0.073815 seconds and 5 git commands to generate.